Back to overview
Maintenance
Plex Server Offline for Today and Tomorrow
Mar 11, 2026 at 5:45pm UTC
–
Mar 13, 2026 at 9:08am UTC
Affected services
Plex Media Server
Requests
Resolved
Mar 13, 2026 at 9:08am UTC
The Plex server is back online - there is still some missing content which will slowly be re-added.
Affected services
Updated
Mar 11, 2026 at 10:43pm UTC
The server will be offline for today and possibly tomorrow due to a device failure.
Affected services
Created
Mar 11, 2026 at 5:45pm UTC
Plex Server Offline for Several Hours Today for Maintenance
Affected services